TVShows fails to download some, but not all, shows

Jon's Avatar


09 Dec, 2014 06:18 AM

I use custom trackers for all my shows, mostly from a single site that provides a public URL.

Most shows record just fine, no problems. But for months now certain shows will sometimes (but not always) fail to record. When this happens, there are two different scenarios:

1. The show does not even appear to exist at the site in question, and TVShows displays NO episodes containing any part of that show's name. This is despite the episode very clearly existing at the site.
2. The show appears in TVShows, but does not download. Manually clicking the download link, also fails to do anything.

This will happen inexplicably, and then the next week that show might download fine. Or not. I never know until it happens.

Does anyone know what causes this?

  1. 1 Posted by Jon on 13 Dec, 2014 05:06 AM

    Jon's Avatar

    Any word on this? It's extremely frustrating.

  2. 2 Posted by Bob on 13 Dec, 2014 10:56 AM

    Bob's Avatar

    Probably has something top do with torrent site being dow i guess...

  3. 3 Posted by Jonathan van Cl... on 13 Dec, 2014 04:34 PM

    Jonathan van Clute's Avatar

    No it definitely does not, because I can go right to the torrent site and see that everything is up and fine, and I can even download the shows directly that TVShows is failing to pick up.

  4. 4 Posted by Bob on 13 Dec, 2014 04:44 PM

    Bob's Avatar

    Do you mean TPB "copycats" that they warn people about ;) At least the original TPB is dead, and EZTV is slowly recovering. I don´t know about the rest of the sites that were affected. Too bad for this app.

  5. 5 Posted by Jon on 13 Dec, 2014 08:55 PM

    Jon's Avatar

    No, I'm not referring to using TPB at all. I don't use it for any of my downloads, I strictly use private torrent sites. This has been going on for months and has absolutely nothing to do with the recent TPB troubles.

  6. 6 Posted by Bruce on 13 Dec, 2014 09:10 PM

    Bruce's Avatar

    Use a different RSS for your shows. By the way, what do you mean you use private torrent sites? There's no option to choose where to download from.

  7. 7 Posted by Jon on 13 Dec, 2014 09:12 PM

    Jon's Avatar

    You can set up private RSS feeds and download from wherever you like. I download strictly from private sites, so I add all my shows manually. This is not a problem with the RSS feed, because the same feed will work most of the time for most shows. It will fail sometimes, for different shows. No show consistently fails 100% of the time. Different shows fail at different times with no rhyme or reason.

  8. 8 Posted by Jon on 13 Dec, 2014 09:17 PM

    Jon's Avatar

    Also I should reiterate - sometimes when TVShows is failing to download a show, I will go check it and see that the next episode of the show IS SHOWN in TVShows itself. But it simply will not download - even manually clicking the download button.

  9. 9 Posted by Jon on 18 Jan, 2015 07:18 PM

    Jon's Avatar

    Any news on this by chance?? My shows all show up as they should, because I don't use TPB and only use private trackers. BUT not TVS won't download anything at all. No shows get downloaded whatsoever. Even clicking on the download button manually, does nothing.

    Is the app itself just completely dead now, TPB issues aside?

  10. 10 Posted by Bob on 18 Jan, 2015 07:44 PM

    Bob's Avatar

    That is odd behaviour, very weird. The app started working again, for me at least, it seems to work just fine. So not completely dead.

  11. 11 Posted by Jon on 19 Jan, 2015 03:13 AM

    Jon's Avatar

    I don't know what to do then... for me, it no longer works consistently at all. Certain shows actually ARE apparently downloading - Doctor Who for example. But others just simply will not (nearly anything else) despite them being clearly available in the RSS feed, and being perfectly downloadable directly from the site in question.

    This never used to happen, and started before TPB went down... at least a couple months before. I don't see any definite pattern or cause, and am at a loss as to what to do about it. At this point, TVS is so unreliable as to be basically useless, and I've had to resort to Season Passes on my TiVo for all my shows, or manually downloading episodes myself as they become available.

    I know this is a freeware program and that the developer only works on it "in his spare time", but it sure would be nice to hear from him (or someone who can officially speak for him) at some point.

  12. 12 Posted by Michael on 19 Jan, 2015 10:23 AM

    Michael's Avatar

    For me it's not downloading automatically however when I click on the download button in the subscriptions section it then adds them to transmission.

  13. 13 Posted by Jon on 19 Jan, 2015 03:44 PM

    Jon's Avatar

    Yeah sometimes it does that for me... clicking manually will add to UTorrent occasionally, but mostly not. And it *almost* never downloads automatically anymore, but not 100% of the time. It's the inconsistency that makes it impossible to pin down what's going on. But it's incredibly frustrating and disappointing. Been using TVS for years and I love the concept... but it seems like I should start looking for another solution pretty soon. =(

  14. 14 Posted by Jon on 30 Jan, 2015 03:51 PM

    Jon's Avatar

    Holy crap I think I solved the problem!!

    I never use TPB, I use only private trackers. So there is an option to "prioritize magnet links" which TVS says to use only if TPB is blocked.

    Well since I don't use TPB anyway, I never checked this option. Just now for the heck of it, I enabled it... and instantly shows started downloading!

    So if you're having this problem of TVS no longer downloading - even if you don't use TPB - try prioritizing magnets. Hope it helps someone else!

  15. 15 Posted by Jon on 14 Feb, 2015 03:26 AM

    Jon's Avatar

    For whatever it's worth, my "solution" lasted less than a day. After the initial surge of downloads started, I'm back to sporadic downloading, without any rhyme or reason that I can detect. I've tried every combination of settings in TVS and there's no change, and I've tried two different private tracker sites, both behave identically. So for some reason TVS seems to just plain not really work anymore. What a shame. :(

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac