Actually 2: Downloads of avi or mkv rather than mp4; and 18 hour to download programs

rap4email's Avatar


15 Mar, 2014 06:39 PM

Problem 1: How can I download just mp4's, which with .mov files, are the only files that will work on AppleTV?
Problem 2: It takes 18 hours to download a program, and it's usually an mkv format. Is there something in my preferences that does that?
Downloading .avi or .mkv files are useless unless I convert them. I can download a .mp4 format generally 5 hours after the program finishes, but TVShows 2 is supposed to do this automatically. What do I have to change? .mp4 files are available for such shows as Hannibal on Extratorrent, TPB, and KAT. Thanks.

  1. 1 Posted by Carlos on 15 Mar, 2014 07:17 PM

    Carlos's Avatar

    I'm having this problem too, mainly from files, the ones that come with a folder name [] and so. I agree that an option to select only mp4 files to be downloaded would be great, even if it meant for the download to wait a little longer before starting.

    It would add to the already wonderful ease of use and automated use that's this program's excellent plus ^.^

  2. 2 Posted by Bob on 19 Mar, 2014 12:10 PM

    Bob's Avatar

    I also share this problem.

  3. 3 Posted by tom on 20 Mar, 2014 03:49 AM

    tom's Avatar

    If anyone has any tips on this i would love to hear em.

  4. 4 Posted by Bob on 21 Mar, 2014 06:16 PM

    Bob's Avatar


  5. 5 Posted by SM on 23 Mar, 2014 01:14 PM

    SM's Avatar


    i sync everything to ipad so would be good to have mp4 back.


  6. 6 Posted by Arnaud on 27 Mar, 2014 10:33 PM

    Arnaud's Avatar

    From what I see, root cause is default RSS feeds from TVShows that are now providing mostly links to mkv and avi instead of mp4...

    Only workaround I found:
    1) Edit your Show definition in TVShows 2) You'll see the default RSS feed URL (e.g. for Game of Thrones: 3) Replace this URL by another RSS feed providing links to mp4 files

    I found some correct RSS feeds here: (pick a show and get the public feed address): e.g. for GoT you'll get:

    With these feeds I get mp4 files quite fast after program is aired.

    Only remaining issue: I also often get several hours later the same episode downloaded again in HD (mkv). So I have to delete this one...

  7. 7 Posted by rap4email on 28 Mar, 2014 11:45 AM

    rap4email's Avatar

    Me again. I was all set to try Amaud's workaround, and turned on TVShows 2. It's been turned off for a few weeks, as I don't need .avi's and .mkv's. It immediately started to download about 30-35 shows, ALL in .mp4 format. I guess they fixed the problem, but I'll keep Amaud's workaround handy in case it reverts back to the wrong (in my case) format. Thanks to Amaud and all the people that responded.

  8. rap4email closed this discussion on 28 Mar, 2014 11:46 AM.

  9. Bob re-opened this discussion on 28 Mar, 2014 11:51 AM

  10. 8 Posted by Bob on 28 Mar, 2014 11:51 AM

    Bob's Avatar

    It started to work for me as well (so far). Everything but From Dusk Till Dawn The Series has downloaded smoothly, hopefully it will work for everything (-else) in the future.

  11. 9 Posted by Sal on 27 Apr, 2014 06:10 AM

    Sal's Avatar

    I too would love an option to disable mvk downloading. Neither Plex, Apple TV nor Xbox streaming will play these files, even if I convert them to other formats. I know that if you deselect HD it'll make TVShows 'prefer' mp4 etc over mkv, but I don't want ANY mkv and would rather just wait for mp4 or avi (or find the correct show myself).

    Loving TVShows so far, but adding a checklist for formats would make it perfect!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac