“TVShows.prefPane” is damaged and can’t be opened. You should move it to the Trash.

Tom Hesser's Avatar

Tom Hesser

12 Nov, 2013 06:17 AM

That's the message I get when I try to install 2.1 on Mavericks on my iMac. Actually, 2.0 seems to be working fine so far.

  1. 1 Posted by E on 12 Nov, 2013 07:37 AM

    E's Avatar

    that's because the Archive Utility (the OS X built-in app) doesn't unzip that file properly so you would want either Stuffit Expander or Unarchiver to uncompress it and you won't get that error.

  2. Support Staff 2 Posted by Cristina Gómez on 12 Nov, 2013 09:10 PM

    Cristina Gómez's Avatar

    Hi all,

    Thanks E for putting us in the right track, we had tested the app internally and never came up with that issue, we must be using the right app ;)

    We are running some tests now, it seems the issue only affects Mavericks (I'm still using Mountain Lion and I can unzip it with any app in my computer and it will work). Can you confirm you were able to use the file unzipped by Unarchiver? Because I have tried on a Mac running Mavericks and it didn't work. I don't have Stuffit Expander right now, but I used BetterZip and it worked.

    EDIT: one more thing I tried, if I unzip it using my Mac on Mountain Lion (using any app I have, I have tried Unarchiver and the OS X Archive Utility) and then move the unzipped version to the Mac running Mavericks, it works.

    For the moment we have taken down the build from our website, but if you still have the zip and would like to make it work and/or help us determine the issue, a couple of ideas:

    • Try different unzip apps if you have them, or unzip it in a Mac not running Mavericks if you have one.
    • Post here the combination OS - app and whether it worked or not so we can see if it is consistent or not.

    Thank you and sorry for the inconvenience!

  3. 3 Posted by brian.leveille on 12 Nov, 2013 09:41 PM

    brian.leveille's Avatar

    I tried both the unzip util on the command line and stuff-it expander after re-downloading the zip, and freaked out when it kept installing 2.0!

    I came back to this thread and saw the note about the 2.1 build being pulled and found the 2.1 zip file in my trash. Pulled 2.1 out of my trash, unzipped it with stuffit expander and it installed just fine.

    Also, 2.1 seems to stay running now too! Yay!

    So the combo of stuffit-expander and 2.1 works on my Mavericks system.

    Thanks all,


    p.s. I just went back and tried /usr/bin/unzip on the 2.1 download and it fails to install. I only have success with opening the 2.1 file with stuffit-expander.

  4. 4 Posted by Angel on 12 Nov, 2013 09:46 PM

    Angel's Avatar

    Hi All, I was able to finally install the prefpane.

    Basically what I did is change in the security preferences pane "the allow applications from" into "Anywhere". I installed it and changed back my preferences. The app seems working fine.


  5. 5 Posted by datalorew on 13 Nov, 2013 01:18 AM

    datalorew's Avatar

    I can confirm with Angel's workaround I too was successful at installing 2.1 without issue.

  6. 6 Posted by Thomas HESSER on 13 Nov, 2013 01:42 AM

    Thomas HESSER's Avatar

    Unarchiver didn't work, but StuffIt Expander did. Seems to be working ok now. Strange thing, downloading also changed the file name to TVShows-630.zip. Not sure why that was happening. Might be part of the problem. Can't remember how I got it to download as TVShows.zip.

  7. Support Staff 7 Posted by Cristina Gómez on 13 Nov, 2013 09:48 AM

    Cristina Gómez's Avatar

    Hi all,

    Thanks for all the replies. Thanks Angel, I just checked and changing that preference makes all the previous non-working unzipped files to work, wo we'll look into that... it's weird because even without changing the security preferences, it works using some unzip apps, and the error message is not related at all with permissions :S

    2.1 is back on the website. Thomas, the naming isn't important in this case (releases are managed by GitHub, which usually has a TVShows.zip file that is always the latest version, but somehow the website is pointing to the specific r630 file instead of the general one, we'll look into that as well).

  8. 8 Posted by pr0xyfl00d3r.20... on 13 Nov, 2013 10:42 PM

    pr0xyfl00d3r.2007's Avatar

    The site is still linked to the old version!!! how do you install the one from github?

  9. 9 Posted by pr0xyfl00d3r.20... on 13 Nov, 2013 10:44 PM

    pr0xyfl00d3r.2007's Avatar

    the site still downloads the old 2.0 app

  10. 10 Posted by hawk on 13 Nov, 2013 11:53 PM

    hawk's Avatar

    Same here. It downloads 2.0, not 2.1 The download itself is "TVShows-616.zip". When I install and then go to the prefpane it says it's v2.0(r616).

  11. 11 Posted by cmaddy1320 on 14 Nov, 2013 01:26 AM

    cmaddy1320's Avatar

    No torrents are downloading for me

  12. Support Staff 12 Posted by Cristina Gómez on 14 Nov, 2013 06:36 AM

    Cristina Gómez's Avatar

    Hi all,

    Version 2.1 may not be available while we look into the issue, sorry for the inconvenience.

    cmaddy1320, yours is a different issue, in order to simplify support, please refer to this discussion for more information and reply there if you have any more questions.

  13. 13 Posted by hawk on 14 Nov, 2013 10:35 AM

    hawk's Avatar

    I downloaded because of the last post made by you Christina: "2.1 is back on the website. Thomas, the naming isn't important in this case (releases are managed by GitHub, which usually has a TVShows.zip file that is always the latest version, but somehow the website is pointing to the specific r630 file instead of the general one, we'll look into that as well)."
    I guess I shouldn't have gotten my hopes up that 2.1 was actually on the website... :( The website even says 2.1

  14. 14 Posted by bachel on 14 Nov, 2013 04:10 PM

    bachel's Avatar

    Is their any other way to get the 2.1 because the site is still downloading 2.0 and the update function in the programm does not work

  15. 15 Posted by Edward Cantrell on 14 Nov, 2013 06:40 PM

    Edward Cantrell's Avatar

    Edward Cantrell
    Sent from my iMac

  16. 16 Posted by pr0xyfl00d3r.20... on 14 Nov, 2013 07:42 PM

    pr0xyfl00d3r.2007's Avatar

    Is there any news on 2.1?

  17. Support Staff 17 Posted by Cristina Gómez on 14 Nov, 2013 08:52 PM

    Cristina Gómez's Avatar

    Hi all,

    hawk, when I posted that message the 2.1 version was available again on the website, but it was taken down afterwards. I don't know why the developer has pulled it again (I haven't been able to contact him).

    Everybody: if the latest available version in the website is 2.0 and the app isn't detecting an update, the app is working perfectly!!!

    We will post here when 2.1 is available again.

  18. 18 Posted by Tom on 14 Nov, 2013 11:26 PM

    Tom's Avatar

    Christina, would it be appropriate for my to post a Dropbox link to the 630 build I downloaded until 2.1 is reposted? Keep in mind I'm not sure how much bandwidth I'm allowed, so I would only want it on this thread.

  19. 19 Posted by bachel on 14 Nov, 2013 11:32 PM

    bachel's Avatar

    I would take it and try it

  20. 20 Posted by justme on 15 Nov, 2013 02:35 AM

    justme's Avatar

    Cristina, you pointed me here fem this thread - http://support.tvshowsapp.com/discussions/problems/2684-feeds-missing

    I download from your site here http://tvshowsapp.com click Download 2.1 (Universal)
    Leopard, Snow Leopard, Lion, Mountain Lion & Mavericks. It unzips and my current 2.0 is the Preference Pane.

    SO I go to my MacBook Pro running Lion, download - same results - 2.0. So I download Stuffit Expander, re-download and use Stuffit Expander - 2.0 So I go to Macupdate and download TVshows 2.1 from them - NOPE - unzip it is 2.0

    So is 2.1 pulled?

  21. Support Staff 21 Posted by Cristina Gómez on 15 Nov, 2013 10:11 AM

    Cristina Gómez's Avatar

    Hi all,

    Tom, I'd prefer you wouldn't. It is available on our GitHub (so advanced users can download it at their own risk), but I'm not posting the link because I don't know the implications and prefer to wait until the developer can sort it out.

    allowmetopost, can you please read this discussion? I have already said that 2.1 has been pulled.

  22. 22 Posted by hawk on 20 Nov, 2013 12:36 AM

    hawk's Avatar

    I just wanted to say that today while I was downloading some episodes manually the feed started working again. Which is great! So, I went to the main site and downloaded the app and it turned out to be 2.1 and not 2.0. Everything seems to be working fine now, but I'll know for sure in a few days. Thanks to you and the team. I'm so glad that TVShows is now working again. :)

  23. Support Staff 23 Posted by Cristina Gómez on 25 Nov, 2013 08:53 AM

    Cristina Gómez's Avatar

    Hi all,

    As hawk says, version 2.1 has been published again, it is a different release than the one posted before (that was r630 and this one is r631) so if you had r630 (the release number is shown next to the version number, on the bottom left corner of the TVShows window) please update (the app should detect the new version, but if it doesn't, just download it from our website.

    There's more information about the recent issues on our blog.

  24. Cristina Gómez closed this discussion on 18 Dec, 2013 08:53 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac