TVShows won't start automatically after boot on ML 10.8.3

tovkal's Avatar


27 Mar, 2013 08:21 AM


TVShows was running fine on 10.8.2: You boot up the computer (or scheduled startup) everything would start, TVShows would appear on the menu bar, search for new torrents and so.

But after I upgraded to 10.8.3, after startup, TVShows won't appear anymore on the menubar, only after I go to preference pane and click the icon there it will start, search for torrents, etc.

I tried reinstalling the app, uninstalling it and reinstalling, using the command that's suggested here without any luck.

  1. Support Staff 1 Posted by Cristina Gómez on 09 Apr, 2013 02:30 PM

    Cristina Gómez's Avatar

    Hi Tovkal,

    Sorry for the late reply. I don't think this is related to the OS X version, because noone else seems to be having this issue (also, I recently updated two Macs to 10.8.3 and TVShows still starts automatically).

    What errors did the commands from the Knowledge Base produce? Can you send us the log? (About tab -> View logs, please paste the content into a text file and attach it to the message)

  2. 2 Posted by tovkal on 09 Apr, 2013 02:44 PM

    tovkal's Avatar


    I had already looked at the log, but there's no relevant message:

    2013-04-09 14:01:20.694 INFO: [616 ~ Downloader] Downloading an updated show list.
    2013-04-09 14:01:23.436 INFO: [616 ~ Downloader] Finished downloading the new show list.
    2013-04-09 14:01:23.497 INFO: [616 ~ Downloader] Checking for new episodes.
    2013-04-09 15:01:19.920 INFO: [616 ~ Downloader] Using a cached show list (2013-04-09 12:01:23 +0000).

    And so on... Probably doing a clean install would solve the issue, but I don't know what I messed up when installed 10.8.3 late March (installed 10.8, upgraded to 10.8.3 and imported my files from a backup... Probably with the future version of TVShows, 3.0 as a standalone app would have work fine)...

    The workaround I found was to drag the TVShows.prefPane file to the Login Items of my user, so that on boot the pane opens and TVShows does his thing and I just need to close the window.

  3. Support Staff 3 Posted by Cristina Gómez on 09 Apr, 2013 02:50 PM

    Cristina Gómez's Avatar

    Hi Tovkal,

    It seems a permissions issue, so I don't know why the KB commands didn't work.

    Can you try uninstalling and reinstalling the newest version from scratch? In order to do that, follow these steps:

    1. Backup the folder ~/Library/Application Support/TVShows 2/ (subscriptions) and the file ~/Library/Preferences/com.victorpimentel.TVShows2.plist (preferences)
    2. Empty the trash, if it isn't empty.
    3. Go to the About tab, click the uninstall button.
    4. Open System Preferences (not TVShows PrefPane), if the PrefPane is still here, right click it and remove it.
    5. Download the latest version from our website, and install it (if prompted, select "only for this user").
    6. If everything works, copy the backup of your subscriptions into the Application Support folder and the .plist file to the Preferences folder.
  4. 4 Posted by tovkal on 09 Apr, 2013 03:27 PM

    tovkal's Avatar

    Just did all this (I had previously done a couple of uninstalls trying different things, except the trash step) and no luck. After the install, I tried to use the terminal command, nothing. Repair disk permissions, nothing.

  5. 5 Posted by Alex on 25 Nov, 2013 08:03 PM

    Alex's Avatar

    Same thing for me; but strangely it is since I installed TVShows 2.1 on a new Mavericks OS X 10.9 (13A3017) running on a MacBook Pro (15" Retina, Late 2013). My friend has it running fine on his; while mine doesn't show start up when I restart, it won't show on the menu bar, and it won't even fetch the files online.

    I've tried reinstalling by properly uninstalling it first; and doing each item on your email Cristina. I still can't get it to work - and I LOVE my life with this TVShow app. It makes things so much easier.

    Looking forward to a solution (if there are any) :-)

  6. 6 Posted by tovkal on 25 Nov, 2013 08:12 PM

    tovkal's Avatar

    What I did as a workaround was adding the TVShows.prefPane to the list of Login Items (apps and so that open after login in) in the Users&Groups preferences. The file you need to add it's in /Library/PreferencePanes.

    I'll try shortly if after the 2.1 update and the Mavericks upgrade it's now working on its own or I still need this workaround.
    Edit: Still the same.

  7. 7 Posted by tovkal on 21 Feb, 2014 12:02 PM

    tovkal's Avatar

    I think I figured it out. I'm using two hard drives, a regular one and a SSD. In the SSD I have everything except my User folder, which I moved to the HD leaving a link to the folder (via ln command) in the SSD.

    When installing TVShows, the TVShows.prefPane file goes to the user's folder Library (~/Library/PreferencePanes). For some reason, when the prefPane its on the other drive, the app won't start and appear in the menu bar.

    The solution is easy, move the prefPane file from ~/Library/PreferencePanes to /Library/PreferencePanes, that is, the system's Library. Now it works without the trick of adding the file to the Login Items.

    This works on Mavericks 10.9.1, but I guess it will also work on previous versions.

  8. 8 Posted by Glen Warner on 09 Mar, 2016 03:12 AM

    Glen Warner's Avatar

    I have TVShows running on three different Macs -- two of them running Snow Leopard and the other running Mavericks.

    I got it to work on all of them -- once -- each one using Transmission as the app of choice to handle the download.

    On the iMac, which is the one running Mavericks, I had upgraded Transmission to the latest build, and the next day I got that message about that particular version being infected with malware, so I uninstalled it and installed the newer version.

    Somewhere along the way, my iMac just restarted. I ran Onyx to see what was going on, and it found no problems. Shortly after that, TV Shows found one of my shows and the system asked to download it -- but with Frostfire vice Transmission.

    I stopped that, because it was supposed to be using Transmission, but apparently when I ran Onyx, it made Transmission something that I had never run before, so when I started it, it put up a message window telling me that I had never ran it before or something like that, and asked for permission to run.

    Unfortunately, I didn't get it to check for those shows again after that, so I went to sleep, and when I woke up a few hours later, the menu was gone.

    I tried everything I could find here, and only got the menu item to appear for a few seconds before vanishing again.

    That said, a couple of suggestions.

    TVShows should have a way to specify which torrent program it's supposed to use.

    it would also be nice if you could check for new episodes without having to use the menu, which seems to vanish at the most inopportune times.

    Finally, I am being forced to upgrade my MacBook Pros from Snow Leopard, which is why I need TVShows to work. The way I usually download TV shows on those MacBook Pros is through something I found somewhere that showed you how to make your .tmp folder where the temp Flash files are stored visible, so all I would have to do would be to go somewhere like CouchTuner, start the show I want to see playing, locate that Flash file, monitor its size, and, when it stops growing, rename it, then move it via DropBox to the iMac for later viewing.

    Unfortunately, I have yet to find a way to do that on Mavericks.

    Sorry for the novel! Looking forward to TVShows 3.0.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac